Proxmark3 community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.

"Learn the tools of the trade the hard way." +Fravia

You are not logged in.


Time changes and with it the technology
Proxmark3 @ discord

Users of this forum, please be aware that information stored on this site is not private.

#1 2023-01-26 21:31:37

Registered: 2020-02-03
Posts: 23

csetuid results in still getting BCC errors upon hf search

Using the hf mf csetuid command to try and set UID of a Gen1a Magic Card after restoring data to it from a dump of another Mifare Classic 1K card. When I run the command, it shows it sets the UID successfully and shows "Verified" but then when I run hf search I get the below:

[usb] pm3 --> hf search
?  Searching for ISO14443-A tag...[#] BCC0 incorrect, got 0x8e, expected 0xe8
[#] Aborting
pm3 -->

I thought csetuid is supposed to correctly set the BCC value? Any ideas what is wrong here? If I then wipe the card with hf mf cwipe to restore default, hf search picks up the card again with all the default data on it, so I don't think anything is wrong with the magic card itself....

EDIT: Was my mistake, didn't realize the cards I had were 4 byte UID only and that they aren't interchangeable when trying to write a 7 byte UID.... If I try to write a new 4 byte UID to these cards it works so assuming if I get 7 byte magic cards it will solve the issue above. Leaving this up for future reference for anyone with similar problem. smile

Last edited by ilovepancakes (2023-01-26 23:39:44)


Board footer

Powered by FluxBB